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Abstract	

Lorem [1] ipsum dolor sit amet, consectetuer adipiscing elit. Proin in diam. Nam dignissim 
facilisis lorem. Aliquam orci ipsum, egestas non, pretium at, venenatis in, felis. Pellentesque 
pellentesque. Vivamus in mi. Suspendisse cursus, augue quis malesuada mollis, massa lorem 
accumsan est, sed vulputate est nibh id pede. 

Suspendisse libero quam, blandit in, euismod a, convallis eget, leo. Sed suscipit arcu eget pede. 
Phasellus laoreet, arcu et vestibulum mollis, erat sem malesuada tortor, et sollicitudin orci 
ipsum et ante. Curabitur hendrerit turpis nec nunc. Maecenas quam lacus, convallis nec, sagittis 
vel, posuere vel, elit. 

Donec tempor egestas nisl. Vestibulum purus lorem, pellentesque faucibus, porta non, aliquet 
at, turpis. Etiam sodales nunc a ipsum. Sed in arcu. Aenean lorem. Morbi vitae sem in mi 
fringilla semper. Quisque vel dolor quis lacus consectetuer ornare. Mauris rutrum risus ut 
massa. Donec vel nibh. Duis pellentesque tristique nulla. 
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Preamble	

Foreword	

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Proin in diam. Nam dignissim facilisis 
lorem. Aliquam orci ipsum, egestas non, pretium at, venenatis in, felis. Pellentesque 
pellentesque. Vivamus in mi. Suspendisse cursus, augue quis malesuada mollis, massa lorem 
accumsan est, sed vulputate est nibh id pede. 
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Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Proin in diam. Nam dignissim facilisis 
lorem. Aliquam orci ipsum, egestas non, pretium at, venenatis in, felis. Pellentesque 
pellentesque. Vivamus in mi. Suspendisse cursus, augue quis malesuada mollis, massa lorem 
accumsan est, sed vulputate est nibh id pede. 

Notations	and	Conventions	

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Proin in diam. Nam dignissim facilisis 
lorem. Aliquam orci ipsum, egestas non, pretium at, venenatis in, felis. Pellentesque 
pellentesque. Vivamus in mi. Suspendisse cursus, augue quis malesuada mollis, massa lorem 
accumsan est, sed vulputate est nibh id pede. 
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	1	
Introduction	

1.1	Template	purposes	 1	
1.2	How	to	use	this	template?	 1	

1.1 Template	purposes	

This template has been created for official documents purposes like thesis or other scientific 
reports. Feel free to use this template as long as you respect the Terms of Use described in 
section 3. 

1.2 How	to	use	this	template?	

The next chapters will introduce the main aspects1 that you should know about this template. 
We encourage you to print this template before you begin to write your document. 

 

                                                
1 For further support, take a look at Microsoft Office Online website: http://office.microsoft.com 
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	2	
Using	this	template	

2.1	Headings	 2	
2.2	Table	of	contents	(TOC)	 2	

2.2.1	Main TOCs .................................................................................................................3 
2.2.2	Chapter TOCs .............................................................................................................3	

2.3	 Illustrations	 3	
2.3.1	Figures ........................................................................................................................3	
2.3.2	Tables .........................................................................................................................4	
2.3.3	Captions ......................................................................................................................4	

2.4	Fields	 5	
2.4.1	 Insert a Field ...............................................................................................................7	
2.4.2	Edit a Field .................................................................................................................7	
2.4.3	Update Fields ..............................................................................................................7	

2.5	Bookmarks	 8	
2.5.1	Add a bookmark .........................................................................................................8	

2.1 Headings	

In order to build Table of contents (TOC), it is recommended to mark your headings by 
choosing the corresponding level style (“[1] H1”, “[1] H2”, “[1] H3”, “[1] H4”). 

2.2 Table	of	contents	(TOC)	

A table of contents is a reader's map. It provides an overview of what is in the document and 
helps readers find a particular section quickly. 

A TOC may be a simple list of chapter titles, or it can include several heading or outline levels. 
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2.2.1 Main	TOCs	

In this document, main TOCs are used to build the “Table of Contents”, “List of Figures”, “List 
of Tables” and “List of Source Code”. If you have correctly marked your heading, you will be 
able to insert a table of contents (TOC). 

1. Click where you want to insert the table of contents, usually at the beginning of a document. 

2. On the References tab, in the Table of Contents group, click Table of Contents, and then 
click the table of contents style that you want. 

 
Figure 2.1: The Table of Contents group of the References tab 

If you want to specify more options — for example, how many heading levels to show — 
click Insert Table of Contents to open the Table of Contents dialog box. 

2.2.2 Chapter	TOCs	

In order to include a table of contents of the current chapter only, create a field with the 
following content: 

1 { TOC \o "2-3" \h \b Chapter2 \t "[1] H2;1;[1] H3;2" } 

Code 2.1 : The field value for a chapter TOC 

The entries of the TOC will be built from the headings retrieved within the bookmark \b 
Chapter2. Take a look into section 2.6 to learn more about bookmarks. 

2.3 Illustrations	

2.3.1 Figures	

Figures will be formatted with the “[2] Figure” style. In order to build the List of Figures TOC, 
you will have to assign a caption  to each one. See section 2.3.3 for more information about 
Captions. 
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Figure 2.2: A figure with an associated caption 

2.3.2 Tables	

Table formatting is done by applying the “[2] Table” style. Furthermore, you can apply “[2] 
Table Header” on the header cells of your table and “[2] Table Contents” on the other table 
cells. Table captions are handled in the same way as figure Captions, described in section 2.3.3. 

Column 1 Column 2 Column 3 
1 2 3 
4 5 6 
7 8 9 

Table 2.1 : An example of a formatted table 

2.3.3 Captions	

A caption is a numbered label, such as Figure 1, that you can add to a figure, a table, an 
equation, or another object. 

Add	a	caption	
1. Select the object (table, equation, figure, or another object) that you want to add a caption 

to. 

2. On the References tab, in the Captions group, click Insert Caption. 

 
Figure 2.3: The Captions group from the References tab. 

3. In the Label list, select the label that best describes the object, such as a picture or equation. 
If the list doesn't provide the correct label, click New Label, type the new label in the Label 
box, and then click OK. 

4. Type any text, including punctuation that you want to appear after the label. 

5. Select any other options you want. 



2	Using	this	template	 	 Index	

5 

You can quickly add a caption to an image by right-clicking on it and selecting “Add a 
caption…”. 

Add	a	caption	with	the	current	chapter	number	
If you want to include the current chapter number into the caption, you have to use the following 
field: 

1 { STYLEREF "[1] H1" \s } 

Code 2.2 : The field value for the current chapter number 

2.4 Index	

An index lists the terms and topics that are discussed in a document, along with the pages that 
they appear on. To create an index, you mark the index entries by providing the name of the 
main entry and the cross-reference in your document, and then you build the index. 

2.4.1 Index	entries	

Mark	words	or	phrases	
1. To use existing text as an index entry, select the text. To enter your own text as an index 

entry, click where you want to insert the index entry. 

2. On the References tab, in the Index group, click Mark Entry. 

 
Figure 2.4: The Index group from the References tab. 

3. To create the main index entry that uses your own text, type or edit the text in the Main 
entry box. 

4. If you want, you can customize the entry by creating a subentry (subentry: An index entry 
that falls under a more general heading. For example, the index entry "planets" could have 
the subentries "Mars" and "Venus."), a third-level entry, or a cross-reference to another 
entry: 

- To create a subentry, type the text in the Subentry box. 

- To include a third-level entry, type the subentry text followed by a colon (:), and then 
type the text of the third-level entry. 
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- To create a cross-reference to another entry, click Cross-reference under Options, and 
then type the text for the other entry in the box. 

5. To format the page numbers that will appear in the index, select the Bold check box or the 
Italic check box below Page number format. 

To format the text for the index, select the text in the Main entry or Subentry box, right-
click, and then click Font. Select the formatting options that you want to use. 

6. To mark the index entry, click Mark. To mark all occurrences of this text in the document, 
click Mark All. 

7. To mark additional index entries, select the text, click in the Mark Index Entry dialog box, 
and then repeat step 3 through step 6. 

Mark	words	or	phrases	for	text	that	spans	a	range	of	pages	
1. Select the range of text that you want the index entry to refer to. 

2. On the Insert tab, in the Links group, click Bookmark. 

 
Figure 2.5: The Links group from the Insert tab. 

3. In the Bookmark name box, type a name, and then click Add. 

In the document, click at the end of the text that you marked with a bookmark. 

4. On the References tab, in the Index group, click Mark Entry. 

5. In the Main entry box, type the index entry for the marked text. 

6. To format the page numbers that will appear in the index, select the Bold check box or the 
Italic check box below Page number format. 

To format the text for the index, select the text in the Main entry or Subentry box, right-
click, and then click Font. Select the formatting options that you want to use. 

7. Under Options, click Page range. 

8. In the Bookmark box, type or select the bookmark name that you typed in step 3, and then 
click Mark. 

2.5 Fields	

Fields are used as placeholders for data that might change in a document and for creating form 
letters and labels in mail-merge documents. These kinds of fields are also called field codes, 
and they are different from the type of fields that are used to enter information, such as on a 
form. 
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2.5.1 Insert	a	Field	

1. Click where you want to insert a field. 

2. On the Insert tab, in the Text group, click Quick Parts, and then click Field. 

 
Figure 2.6 : The Text group of the Insert tab 

3. In the Categories list, select a category. 

4. In the Field names list, select a field name. 

5. Select any properties or options that you want. 

If you know the field code for the field that you want to insert, you can also type it directly 
in your document. First press CTRL+F9, and then type the code within the brackets. 

2.5.2 Edit	a	Field	

1. Right-click in the field, and then click Edit Field. 

For some fields, you must display the field code to edit the field. To do this, click the field, 
and then press SHIFT+F9. Or, to display all the field codes in the document, press 

ALT+F9. 

2.  Change the field properties and options. For information about the properties and options 
available for a particular field, search on the field name in Help. 

2.5.3 Update	Fields	

1. By default, Word automatically updates fields when a document is opened. That way, 
information stays up to date. There are situations where you might not want this to happen, 
however. For example, you may want the date in the header to reflect a particular date 
rather than automatically updating to the current date every time the document is opened. 

2. Fields can also be updated by right-clicking a field and then clicking Update Field or by 
clicking in a field and then pressing F9. 

To manually update all the fields in the main body of a document, press CTRL+A, and then 
press F9. Fields in headers, footers, or text boxes must be updated separately. Click within 

the header, footer, or text box, press CTRL+A, and then press F9. 
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2.6 Bookmarks	

A bookmark identifies a location or a selection of text that you name and identify for future 
reference. For example, you might use a bookmark to identify text that you want to revise at a 
later time. Instead of scrolling through the document to locate the text, you can go to it by using 
the Bookmark dialog box. 

You can also add cross-references to bookmarks. For example, after you insert a bookmark in 
a document, you can refer to that bookmark from other places in the text by creating cross-
references to the bookmark. 

2.6.1 Add	a	bookmark	

1. Select the text or item to which you want to assign a bookmark, or click where you want to 
insert a bookmark. 

2. On the Insert tab, in the Links group, click Bookmark. 

 
Figure 2.7 : The Links group of the Insert tab 

3. Under Bookmark name, type or select a name. 

4.  Bookmark names must begin with a letter and can contain numbers. You can't include 
spaces in a bookmark name. However, you can use the underscore character to separate 
words — for example, "First_heading." 

5. Click Add. 

To display the bookmarks brackets:  

Click File, and then click Options. 

Click Advanced, and then select the Show bookmarks check box under Show document 
content 

(or click Word, then Preferences, then View if you’re on a Mac). 

Click OK. 
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	3	
Terms	of	Use	

3.1	Authors	 9	
3.2	License	 9	

3.1 Authors	

This template has been created by Pedro DE ALMEIDA from a base template developed by Patrik 
FUHRER (Software Engineering Group, University of Fribourg, Switzerland). 

3.2 License	

This work is licensed under a Creative Commons Attribution 2.5 License. This 
means you may use it for any purpose, and make any changes you like as long as you include 
a reference to the authors of this template, like: 

This documentation is based on a template created by Patrik FUHRER and Pedro DE 

ALMEIDA (Software Engineering Group, University of Fribourg, Switzerland). The template 
is open source and freely available from: [TODO] 

. 
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A	
Source	Code	

1 public class HelloWorld { 
2  /** 
3   * @param args 
4   */ 
5 public static void main(String[] args) { 
6   // TODO Auto-generated method stub 
7   System.out.println("Hello world!"); 
8  } 
9 } 
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B	
Project	Website	

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Proin in diam. Nam dignissim facilisis 
lorem. Aliquam orci ipsum, egestas non, pretium at, venenatis in, felis. Pellentesque 
pellentesque. Vivamus in mi. Suspendisse cursus, augue quis malesuada mollis, massa lorem 
accumsan est, sed vulputate est nibh id pede. 
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C	
CD-ROM	

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Proin in diam. Nam dignissim facilisis 
lorem. Aliquam orci ipsum, egestas non, pretium at, venenatis in, felis. Pellentesque 
pellentesque. Vivamus in mi. Suspendisse cursus, augue quis malesuada mollis, massa lorem 
accumsan est, sed vulputate est nibh id pede. 
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